Back to overview
Degraded

Network issues are blocking app downloads

Mar 30, 2026 at 11:04am UTC
Affected services
iOS Test Runner · default runner type
iOS Test Runner · m4 runner type
Android Runner · default runner type

Resolved
Mar 30, 2026 at 7:13pm UTC

We’re confident this is resolved now. Please don’t hesitate to contact support if you have any issues 🙂

Updated
Mar 30, 2026 at 5:29pm UTC

Things are beginning to recover and we'll continue to monitor for any further issues.
We appreciate your patience whilst we resolved this!

Updated
Mar 30, 2026 at 5:02pm UTC

Our upstream provider is ratelimiting our connections so we're deploying a fix to reduce load.

Updated
Mar 30, 2026 at 3:37pm UTC

We've traced a secondary issue to our upstream provider and are investigating.

Updated
Mar 30, 2026 at 3:17pm UTC

We've issued a patch and are seeing some recovery. We'll continue to monitor & investigate until all is stable.

Updated
Mar 30, 2026 at 2:42pm UTC

We've tracked the root cause to our network stack and are in the process of issuing a patch. We appreciate your patience as we work to resolve this issue.

Updated
Mar 30, 2026 at 2:14pm UTC

We've identified that primarily larger apps are affected. We're continuing to investigate to locate root cause.

Updated
Mar 30, 2026 at 11:48am UTC

We've tracked the issue to our network and are continuing to investigate.

Created
Mar 30, 2026 at 11:04am UTC

We're seeing "Failed to download app" errors occuring on a small portion of tests and are investigating.