Back to overview
Resolved

Slow test queues across iOS and Android

Jun 29, 2026 at 1:13pm UTC
Affected services
iOS Test Runner · default runner type
Android Runner · default runner type

Resolved
Jun 29, 2026 at 2:31pm UTC

Everything has recovered and the queue is draining. Expect extended wait times for a few hours whilst the backlog is cleared. Thanks for your patience!

Updated
Jun 29, 2026 at 2:25pm UTC

Android has been restored and we're monitoring recovery.

Updated
Jun 29, 2026 at 2:17pm UTC

The iOS queue has been restored and is draining properly. We're still working on restoring Android.

Updated
Jun 29, 2026 at 2:08pm UTC

The issue has been traced to a power failure in our datacentre provider which has been rectified. We're watching for recovery and will update when we have more to share.

Updated
Jun 29, 2026 at 1:42pm UTC

We've begun to implement a fix and iOS is beginning to recover. We're still working on a fix for Android.

Updated
Jun 29, 2026 at 1:32pm UTC

We've identified an issue with a portion of our host devices and are working on a fix.

Created
Jun 29, 2026 at 1:13pm UTC

We're aware of slowdowns across both platform queues and are investigating.